Fehlerhaftes Apache mod_rewrite Modul im Oxid Shop

Es tritt folgendes Problem bei einem sonst stabil laufenden Oxid-Shop auf:

Nach dem Einloggen im Backend erhalten Sie eine Warnmeldung aufgrund fehlerhafter Systemgesundheit. Das Apache mod_rewrite Modul steht nun auf rot, ihr seid euch sicher, dass das Modul auf on ist und ihr habt grad keinen Plan, wie man das beheben kann. Die Hauptseite des Shop wird mit etwas Glück noch angezeigt. Mit etwas weniger Glück passiert im Frontend vielleicht sogar gar nichts mehr.

Ein Lösungsansatz könnte sein:

Bitte überprüft, ob im eurem Shophauptverzeichnis die .htaccess Datei vorhanden ist (via ftp).  Sollte sie nicht da sein (weil diese irrtümlich gelöscht wurde oder aus irgendeinem anderen Grund abhanden gekommen ist), habt ihr den Fehler schon gefunden.

Hierfür gibt es leichte Abhilfe:

Ladet euch einfach z.B. eure Oxid CE Version (http://www.oxid-esales.com/en/community/download-oxid-eshop.html) hier herunter, entpackt die Dateien und ladet die dort vorhandene .htaccess Datei in das root Verzeichnes eures Shops.

Wenn ihr nun im Backend die Systemgesundheit überprüft, sollte das Apache mod_rewrite Modul nun auf grün stehen.

So geschehen und gelöst bei mir…



1 Antwort
  1. Avatar
    Heinz sagte:

    ich hatte das problem, dass bei mir das mod_rewrite modul rot markiert war im oxid 6 shop.
    auf einem anderen 4.9.11er shop, welcher auf dem gleichen server parallel lief, war alles grün.

    der unterschied: im 6er hatte ich in der htaccess eine htpasswd eingebunden. wenn ich die authentification rausnehme, ist auch im 6er alles grün 😉

    Antworten

Dein Kommentar

An Diskussion beteiligen?
Hinterlasse uns Deinen Kommentar!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.