OXID eShop v6.0.0 Beta1: System Requirements

Introduction

With OXID eShop 6 series, there will be some changes to the system requirements compared to those of previous versions.
We noticed that hosters tend to upgrade their servers to new stable versions much earlier than they did in the past. The advantages to applications running on those servers are many. New versions tend to be faster, better and the support period for bug fixes and security upgrades increases.

We recommend those system requirements, which we ourselves use in our continuous integration systems and in our performance server cluster, which follow the trend of using new versions in the system environment. These system requirements are listed in the next section.

A small side note: It is utterly impossible to test all of the imaginable configurations and we only recommend those, which we test. This does not necessarily mean that others will not work. There are many tutorials out there on the Internet which describe other configurations, such as running OXID eShop on an nginx web server.

The system requirements

No Encoding for PE or EE

From OXID eShop version 6, the OXID eShop will no longer be encoded. Zend Guard Loader is no longer required.

Webserver

  • Apache Versionen 2.2 and 2.4 (on Linux)
  • Webspace requirements:
      • Community: 500 MB
      • Professional: 500 Mb
      • Enterprise: 750 MB
  • installed mod_rewrite extension

MySQL

  • MySQL versions 5.5 and 5.7

The database user needs sufficient privileges

  • to create a database if the database does not exist already during installation
  • to create views

PHP

  • PHP versions 5.6 and 7.0
  • Set memory_limit at least to 32 MB. We recomend a memory_limit of at least 60MB.
  • PHP setting “session.auto_start” in php.ini has to be set “OFF”
  • We recommend to enable file uploads in PHP
  • Activate allow_url_fopen and fsockopen to port 80
  • Set Apache server variables REQUEST_URI or SCRIPT_URI
  • ini_set allowed

The following PHP-extensions must be installed:

  • GD LIB Version 2.x
  • PDO_MySQL
  • BC Math
  • JSON
  • iconv
  • tokenizer
  • mbstring
  • cUrl
  • SOAP
  • DOM

Remarks

The main reason to raise the PHP version was that PHP itself raised the currently supported versions to 5.6 and 7.0 (see http://php.net/supported-versions.php).
Some other PHP requirements for settings and extensions were adapted to reflect the changes in these PHP versions.

Composer

Composer is needed for installation of the OXID eShop and changes in autoloading of files (not for runtime).
System requirements of Composer can be found here: https://getcomposer.org/doc/00-intro.md#system-requirements


2 replies

Trackbacks & Pingbacks

  1. […] For detailed information regarding the systems requirements, see here. […]

  2. […] OXID eShop V6.0.0 Beta1: System Requirements […]

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *