OXID eShop v6.0.0 RC1 (partner release) is published

OXID eShop v6.0.0 release candidate 1 (AKA “Partner Release”) is publicly available from now on. Please find it with this tag: https://github.com/OXID-eSales/oxideshop_ce/tree/v6.0.0-rc.1 on GitHub.

Information about changes

  • Azure theme is marked as deprecated and will be removed with one of the next major releases.
  • The block admin_order_overview_total  was updated in order_overview.tpl.
  • Extracted duplicated code from admin/tpl/order_article.tpl and order_overview.tpl to admin/tpl/include/order_info.tpl. Change can be found in GitHub commit.
  • The method parseModuleChains() has been marked as deprecated in the Config class. Instead, it will be moved to the class ModuleList in the future. Please see the appropriate GitHub commit.
  • In case the composer require-dev section (–dev) is used, the IDE Helper generator will run on every composer install or update.
  • Module classes that cannot be loaded while activating a module will now show up in admin panel -> modules -> Problematic files. More information can be found in this GitHub commit.
  • The composer vendor directory parameter was removed from config.inc.php. From now on only the VENDOR_PATH constant (see bootstrap.php) is used. In case you will update OXID eShop from previous 6.0 versions, you might need to remove this config option from your config.inc.php file to avoid PHP notices.
  • Only backwards compatible classes (e.g. oxArticle) or classes from the virtual namespace can be extended with modules. When trying to extend a shop class over the edition namespace (e.g. OxidEsales\EshopCommunity), you will get an error.
  • Exception handling was improved. Please read the commit messages for the following commits carefully: fccdaea, d5be54f, 4bae2c4.
  • The PayPal module v4.0.0 has been added to the compilation.

Please find the entire change log (comparison the former version beta.3) on GitHub.

Updating and installing OXID eShop v6.0.0 RC1

The simplest way to install the OXID eShop is to run the Composer command to create a project. By default, Composer installs the OXID eShop Compilation including the development ressources (e. g. OXID Testing Library, IDE helper, Codesniffer). Thus, if you are planning to install the OXID eShop Compilation on production environments, make sure to add the nodev  flag. Please note, that it is not recommended to use the OXID eShop v6.0.0 RC1 in productive environments.

  • For Community Edition run:

  • For Professional Edition run:

  • For Enterprise Edition run:

For updating your project from any 6.0 version to RC1, please edit the metapackage version requirement in your root composer.json file to “^v6.0.0-rc.1” and run composer update.

If you have older then v6.0.0 Beta 3 version, you could be interested in installing the OXID-eSales development tools. In this case, check and add these changes to your root composer.json before running “update”.

Porting existing modules to OXID eShop v6

Please see the post “How to (quickly) port a module to OXID eShop 6.0” for information about how to port existing modules to OXID eShop v6.

Credits

In this release, some pull requests could be merged. We want to gratefully thank

  • @alfredbez for pull request #550
  • @flow-control for pull request #551
  • @michaelkeiluweit for pull request #555
  • @keywan-ghadami-oxid for pull request #447

 

0.00 avg. rating (0% score) - 0 votes
0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *