OXID eShop version 6.0.4

This patch release contains a bug fix and updated components.

Additional changes:

  • In components OXID eShop facts and Doctrine Migration Wrapper the tests are no longer delivered via Composer. If the tests are needed, they can be obtained with composer option “–prefer-source” or via “git clone” of the according repository.
  • To fix a bug for a feature that is available in EE only, it was necessary to make some changes in CE and PE as well.
  • In Doctrine Migration Wrappers, different types of output handlers such as BufferdOutput are possible with PR-4. Until now, only ConsoleOutput could be processed. More information can be found in the documentation of the Symfony API.
  • Due to a security issue in PHPMailer, this class was updated to version 5.2.27.

Compilation

OXID eShop 6.0.4 is published as a compilation with the following components:

  • OXID CE component 6.2.2 (was 6.2.1 )
  • OXID PE component 6.1.2 (was 6.1.1)
  • OXID EE component 6.1.3 (was 6.1.2)
  • Theme “Flow” 3.0.0
  • Amazon Pay 3.1.4
  • GDPR Opt-In 2.1.1
  • Klarna 4.0.1
  • Paymorrow 2.0.1
  • PAYONE 1.0.8
  • PayPal 5.2.2
  • Summernote WYSIWIG-Editor 2.1.1
  • Visual CMS 3.2.1 (PE/EE)

Please find all changes to the former OXID eShop compilation 6.0.3 here

System requirements, update and installation

Install the full compilation

Update from previous v6 compilation versions

Fixed bugs

  • Bug fixes in shop core

GUI changes

  • no storefront changes in this patch release

More resources

  • Download full package
  • Source code documentation
  • All changes in this compilation (OXID eShop 6.0.4)

Credits

Many thanks to you GitHub contributors!



Start the discussion at OXID forums