OXID ESHOP VERSION 6.4.0

To improve security and performance, we have ensured you can now use PHP 8.0.

Note that we no longer support PHP 7.3 since this version has reached end of life.

We have updated the GraphQL and B2B modules also to support PHP 8.0.

Also, we ensured OXID eShop is compatible with the updated modules.

In GraphQL, check out the new file upload handling function, it allows you to upload images or other files.

Use the bug tracker to find the bugs we have fixed.

Note that we no longer provide the Paymorrow module.

Finally, we would like to suggest you to try Moga, an open source OXID theme based on Bootstrap 5.

Download it and find support for it under moga-kit/moga-theme (github.com). Feel free to collaborate and help improve the theme!

Compilation

Find the latest changes to the components contained in the compilation:

  • OXID CE component 6.10.0 ()
  • Theme “Flow” 3.8.0 ()
  • Theme “Wave” 1.6.1 ()
  • Amazon Pay 3.6.8 ()
  • GDPR Opt-In 2.3.3 ()
  • Klarna 5.5.2 (updated from 5.5.1 )
  • PAYONE 1.6.0 (updated from 1.5.1 )
  • PayPal 6.4.0 (updated from 6.3.1 )
  • WYSIWYG Editor + Mediathek 2.4.1 ()
  • Cookie Management with usercentrics 1.2.0 (updated from 1.1.3 )
  • GraphQL 6.0.1: (updated from 5.1 )

You might find information about deprecated code in the linked changelogs. To find out what to use on behalf, use the deprecated list in the source code documentation.

System requirements, update, and installation

Fixed bugs

Find a list of fixed bugs in this compilation under https://bugs.oxid-esales.com/changelog_page.php?version_id=619

Additional resources

  • Find instructions for updating or installing OXID eShop 6.4 under
  • Find the source code documentation under
  • Display the changes in this compilation (OXID eShop 6.4.0) under



0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published.